...una invitación a entrar en el maravilloso mundo de la programación...
 Portada      Noticias      Descargar      Documentación      Foros    


Promedio2

Pseudocódigo: Flexible...   Estricto...   |   Diagramas de flujo: Clásico...   Nassi-Schneiderman...   |   Más ejemplos...

// Calcula el promedio de una lista de N datos utilizando un SubProceso

SubProceso prom <- Promedio ( arreglo, cantidad )
    suma <- 0
    Para i<-1 Hasta cantidad Hacer
        suma <- suma + arreglo[i]
    FinPara
    prom <- suma/cantidad
FinSubProceso

Proceso Principal

    Dimension datos[100]
    Escribir "Ingrese la cantidad de datos:"
    Leer n
    
    Para i<-1 Hasta n Hacer
        Escribir "Ingrese el dato ",i,":"
        Leer datos[i]
    FinPara
    
    Escribir "El promedio es: ",Promedio(datos,n)
    
FinProceso


Powered by: SourceForge.net Logo