Información importante para docentes usuarios de PSeInt

PSeInt permite personalizar algunos aspectos del lenguaje. Para evitar confusión en los alumnos, la idea es que la primera vez que se ejecute el programa, solicite al estudiante elegir un "perfil de configuración" para su universidad/facultad/carrera, definiendo rápidamente y en un solo paso la configuración del lenguaje de acuerdo a las exigencias de su docente. Este mensaje es para solicitar a los docentes que envíen sus perfiles para agregarlos a la lista. Para ello, deben realizar los siguientes pasos:
  1. Ejecute PSeInt (asegúrese de haber instalado la última versión).
  2. Seleccione el ítem "Opciones del Lenguaje (perfiles)" del menú "Configurar".
  3. En el cuadro de diálogo que aparece, haga click en "Personalizar".
  4. En el nuevo cuadro de diálogo que aparece, configure el perfil como lo desee.
  5. Haga click en el segundo botón de la esquina inferior izquierda del cuadro de diálogo (el que muestra un disquete) para guardar el perfil en un archivo.
  6. Seleccione una ubicación cualquiera para el archivo e introduzca una breve descripción del perfil (se recomienda mencionar la institución donde se utiliza, la cátedra o carrera, y el nombre del docente responsable o de quien envía el perfil).
  7. Envíe el archivo por email a zaskar_84<arroba>yahoo.com.ar.
En el correo incluyan además del archivo generado e información de la cátedra donde lo utilizan (nombre de la universidad y facultad o instituto, nombre de la carrera, nombre de la cátedra/materia, docente responsable de la misma, y qué lenguaje de programación real utilizan en las clases luego de la etapa de pseudocódigo). Además, cada perfil se muestra con un pequeño ícono de 24x24px, que tomaré del favicon del sitio web de la institución a menos que sugieran o envíen otro (tengan en cuenta que si el logo de la institución es muy complejo, al reducirlo a 24x24 puede que ya no se reconozca).

Si creen que sería util agregar otras personalizaciones además de las ya implementadas no duden en sugerirlo.


A continuación se muestra un ejemplo escrito Para los perfiles Estricto y Flexible, ilustrando algunas diferencias entre configuraciones:

Proceso Estricto
   
   Definir VAL_MAYOR,ARREGLO,CANT,I Como Enteros;
   
   Dimension ARREGLO[100];
   Escribir "Ingrese la cantidad de numeros:";
   Leer CANT;
   
   Para I<-0 Hasta CANT-1 Hacer
      Escribir "Ingrese un numero:";
      Leer ARREGLO[I];
   FinPara
   
   VAL_MAYOR<-0;
   Para I<-0 Hasta CANT-1 Hacer
      Si ARREGLO[I]>VAL_MAYOR Entonces
         VAL_MAYOR<-ARREGLO[i];
      FinSi
   FinPara
   
   Si VAL_MAYOR % 2 = 0 Entonces
      Escribir "El mayor es ",VAL_MAYOR," y es par";
   Sino
      Escribir "El mayor es ",VAL_MAYOR," y es impar";
   FinSi
   
FinProceso
   Proceso Flexible
   
   
   
   Escribir "Ingrese la cantidad de numeros:"
   Leer CANT
   Dimension ARREGLO[CANT]
   
   Para Cada Elemento de ARREGLO
      Escribir "Ingrese un numero:"
      Leer ELEMENTO
   Fin Para
   
   VAL_MAYOR<-0
   Para Cada ELEMENTO de ARREGLO
      Si ELEMENTO Es Mayor Que VAL_MAYOR
         VAL_MAYOR<-ELEMENTO
      Fin Si
   Fin Para
   
   Si VAL_MAYOR Es Par
      Escribir "El mayor es " VAL_MAYOR " y es par"
   Sino
      Escribir "El mayor es " VAL_MAYOR " y es impar"
   Fin Si
   
FinProceso